如何讓擴充套件「強迫」相容於 Firefox 3.6 或其它更新的版本?

Firefox 3.6 RC1 – 正式版發佈之前的第一個預覽版在前幾天終於釋出了。喜歡嘗鮮的朋友可以點選此「連結」下載。不過,因為目前大部份的擴充套件尚未支援 Firefox 3.6,所以在升級完之後可能會發現很多擴充套件都被停用了。

Firefox 升級到 3.6 之後便可以發現有一些擴充套件因為相容性問題而無法啟用 ▼

不相容的擴充套件

要解決這個問題,除了可以利用「Nightly Tester Tools」來強迫啟用、安裝不相容的擴充之外,還可以進入 Firefox 的內部設定,停用 Firefox 的相容性檢查來達到同樣的目的。

如何關閉 Firefox 3.6 擴充套件相同性檢查?

第一步、在網址列輸入 about:config,按下 Enter 進入內部設定頁面。然後在設定項目清單裡的任何一個地方按下右鍵,點選「新增」→「真假 (Boolean) 值」▼

新增真假值

第二步、在跳出來的「設定名稱」對話框裡輸入 extensions.checkCompatibility.3.6,然後按下「確定」▼

輸入設定名稱

另外,如果你使用的是 Firefox 3.6 Beta 的話,設定名稱必須輸入

  • extensions.checkCompatibility.3.6b

若是 Firefox 3.7 Alpha 的話則是輸入

  • extensions.checkCompatibility.3.7a

以此類推…

第三步、在「輸入 真假值 的值」對話框裡選擇「false」然後按下「確定」▼

選擇設定值 false

完成上述的步驟之後,重新啟動 Firefox。打開「附加元件」管理視窗,我們可以看到雖然之前與 Firefox 3.6 不相容的擴充套件依然還是會顯示不相容的訊息,但是它們已經處於啟用狀態。而且也可以在視窗上面看到「已停止檢查附加元件相容性,您可能有不相容的附加元件。」提醒我們 Firefox 已經停用了擴充套件的相容性檢查 ▼

強迫相容的擴充套件

關閉 Firefox 相容性檢查有可能會出現的問題

大部份與 Firefox 3.6 不相容的擴充套件都能使用這個「強迫相容」的方法讓它們重新啟用,不過在強迫啟用它們之後「有可能」會發生某些擴充套件無法正常運作或是導致 Firefox 不穩定的情形發生,出現這種問題時也只能等待擴充套件作者發佈相容的新版本了。

9 thoughts on “如何讓擴充套件「強迫」相容於 Firefox 3.6 或其它更新的版本?

  1. 一直覺得 “已停止檢查附加元件相容性…" 這行字很礙眼
    關掉重開又會跑出來
    不知道有沒有辦法永遠關掉?

  2. 請問我照你這樣改過後,要如何改回來呢??謝你啊!!因為程式已經更新的..我不會改回來啊!!@@

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *